常用命令

super                        //进入特权模式
system view                  //进入系统配置模式
undo                         //删除
reboot                       //重启设备
vlan batch 2 3               //连续创建vlan 2  3
save                         //保存当前配置  注:用户模式下执行
display this                 //查看当前端口配置
display ip routing-table     //查看路由表
display ip interface brief   //查看交换机当前端口的开放状态

用户密码配置

华为交设备配置密码:

[Huawei]user-interface console 0                             //进入用户console 0
[Huawei-ui-console0]authentication-mode password             //密码身份验证模式
[Huawei-ui-console0]set authentication password cipher root  //设置密码为root

华为交换机添加telnet用户名密码

TELNET不验证配置:

[huawei-vty0-4]authentication-mode none

TELNET密码验证配置:

[huawei] User-interface vty 0 4                              //开启vty 0、1、2、3、4 等5个用户虚拟终端
[huawei-vty0 4] authentication-mode password                 //密码身份验证模式
[huawei-ui-vty0 4] set authentication password simple Huawei //设置密码为Huawei
[huawei-ui-vty0 4] user privilege level 3                    //用户特权级别3

注:simple明文 cipher密文

TELNET aaa验证配置:

用户特权级别

LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。

LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。

LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。

LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等

以太网端口配置实验

端口的工作方式和速率的配置:

[LSW1]interface e0/0/1
[LSW1-Ethernet0/0/1]speed 100               //在e0/1端口配置速度为100Mbit/s
[LSW1]int e0/0/1
[LSW1-Ethernet0/0/1]duplex full             //在e0/1端口配置全双工端口模式
[LSW1]interface e0/0/2
[LSW1-Ethernet0/0/2]speed 100               //在e0/2端口配置速度为100Mbit/s
[LSW1]interface e0/0/2
[LSW1-Ethernet0/0/2]duplex full             //在e0/2端口配置全双工端口模式

进入聚合端口,并把以下两个端口加入聚合端口:

[LSW1]interface Eth-Trunk 1
[LSW1-Eth-Trunk1]quit 
[LSW1]interface e0/0/1
[LSW1-Ethernet0/0/1]eth-trunk 1
[LSW1]interface e0/0/2
[LSW1-Ethernet0/0/2]eth-trunk 1

创建VLAN并把VLAN划入聚合端口:

[LSW1]vlan 10
[LSW1]int vlan 10
[LSW1-Vlanif10]ip address 10.1.1.1 30
[LSW1]interface Eth-Trunk 1
[LSW1-Eth-Trunk1]port link-type trunk
[LSW1-Eth-Trunk1]port trunk allow-pass vlan 10

注:在配置端口汇聚之前,首先要保证 Sw1 和 Sw2 所有汇聚的端口必须工作在全双工方 式下,而且必须工作在相同的速率下(不能工作于自协商模式)。

利用 TFTP 管理交换机配置

用 TFTP 获取文件:

tftp tftp-server get source-file [ dest-file ]                //配置命令中,tftp-server 参数代表 TFTP 服务器的 IP 地址或者主机名;source-file 指的 是要下载的 TFTP 服务器上的文件信息;dest-file 参数代表下载后存储在交换机上的文件名。

用 TFTP 保存文件:

tftp tftp-server put source-file [ dest-file ]                //配置命令中,dest-file 指的是文件上传到 TFTP 服务器的存储目录;

虚拟局域网 VLAN

配置VLAN及所属端口:

access模式:

[Huawei]int g0/0/1                                          //进入g0/0/1端口
[Huawei-GigabitEthernet0/0/1]port link-type access          //配置此端口为
[Huawei-GigabitEthernet0/0/1]port default vlan 2            //默认端口为VLAN2

trunk模式:

[Huawei]interface gigabitethnet 0/0/2                                //进入端口
[Huawei-GigabitEthernet0/0/2]port link-type trunk                    //设置第二个网口>位trunk模式
[Huawei-GigabitEthernet0/0/2]port trunk allow-pass vlan 10 20 30     //设置此端口可以通过的VLAN号
[Huawei-GigabitEthernet0/0/2]port trunk allow-pass vlan all          //表示可以通过所有的带VLAN的帧

创建三层接口:

[Huawei]vlan 2  
[Huawei]int vlan 2                                   //进入VLAN 2
[Huawei-Vlanif2]ip address 10.1.2.1 24               //配置IP地址和子网掩码

单臂路由

进入端口加入vlan:

[Huawei]interface Ethernet0/0/1
[Huawei]port link-type access
[Huawei]port default vlan 4

[Huawei]interface Ethernet0/0/3
[Huawei]port link-type access
[Huawei]port default vlan 8

[Huawei]interface GigabitEthernet0/0/2
[Huawei]port link-type trunk
[Huawei]undo port trunk allow-pass vlan 1    (不删vlan1,会出问题)
[Huawei]port trunk allow-pass vlan 4 8

进入子端口进行封装:

[Huawei]interface GigabitEthernet0/0/1.1
[Huawei]dot1q termination vid 4
[Huawei]ip address 10.0.4.254 255.255.255.0 
[Huawei]arp broadcast enable

[Huawei]interface GigabitEthernet0/0/1.3
[Huawei]dot1q termination vid 8
[Huawei]ip address 10.0.8.254 255.255.255.0 
[Huawei]arp broadcast enable

静态路由

[Huawei]ip route-static 10.1.6.0 24 10.1.4.2         //目的路由跳到下一个地址  注:目的路由和掩码全为0表示所有网络地址(省缺路由)

[Huawei]ip route-static 192.168.3.0 255.255.255.0 192.168.2.2 preference 30 //修改静态路由的优先级为30
>注:路由表内优先级默认为60,数值越低优先级越高
最后修改:2020 年 08 月 06 日 02 : 13 AM